Fix for TMG Reports Stop Working After Installing TMG 2010 SP1

Microsoft explain an issue that might occur after you install Forefront TMG 2010 SP1 and Reports start to show blank result. When this happens, following Alert appears on TMG console:"In this scenario access to report links URLs: http://localhost:8008/ReportServer_ISARS or http://127.0.0.:8008/Reports_ISARS will also fail. This issue might happen in some scenarios where there's a "database logon […]

Share online:

Microsoft explain an issue that might occur after you install Forefront TMG 2010 SP1 and Reports start to show blank result. When this happens, following Alert appears on TMG console:

"In this scenario access to report links URLs: http://localhost:8008/ReportServer_ISARS or http://127.0.0.:8008/Reports_ISARS will also fail. This issue might happen in some scenarios where there's a "database logon failure as showed in error description (error code 0x80040e4d means DB_SEC_E_AUTH_FAILED). To address this issue run the script fixsqlserverlogin_vbs mentioned in article below.

When you run the script, you've to wait for each node to sync with EMS and then run it on second node in case of TMG 2010 Enterprise Edition and on single TMG 2010 server in case of standard server. This script allows admin to change password so that connection to the database can be established using new password and reports can be fetched from that."

More Info: TechNet

[Source]

About The Author

Deepak Gupta is a IT & Web Consultant. He is the founder and CEO of diTii.com & DIT Technologies, where he’s engaged in providing Technology Consultancy, Design and Development of Desktop, Web and Mobile applications using various tools and softwares. Sign-up for the Email for daily updates. Google+ Profile.