H1Siri: Siri Jailbreak for iPhone 4 Surfaces in Cydia, Termed 'Unsafe'

A group of Chinese hacker group was able to create the first fully-featured Siri port called "H1Siri," available on Cydia, lets you use the full range of Siri features on both jailbroken fourth-generation iPod touch and GSM/CDMA iPhone 4 running either iOS 5.0 or the latest 5.0.1 version.The package is only available on a custom […]

H1Siri: Siri Jairbreak fro iPhone 4A group of Chinese hacker group was able to create the first fully-featured Siri port called "H1Siri," available on Cydia, lets you use the full range of Siri features on both jailbroken fourth-generation iPod touch and GSM/CDMA iPhone 4 running either iOS 5.0 or the latest 5.0.1 version.

The package is only available on a custom repo, so you'll have to add a URL to your list of Cydia sources. Do this by opening Cydia, selecting the Manage tab, Sources, Edit, and then add http://www.iphone3gsystem.fr/cydia/. Then just do a search for H1Siri.

According to iClarified, the 100MB download is available via both Cydia.be and iphone3gsystem.fr/cydia repositories (select Manage > Sources > Edit in Cydia, add the sources and do a search for H1Siri).

"Note that H1Siri comes from a relatively unknown party and contains cracks so it's likely illegal. Also note it passes your personal information to a shady third-party server. If you're interested, a how-to guide is available here."

iDownloadBlog noticed that the hack has been found to break some users' iPhones, and potentially worse, compromises the personal data of anyone who chooses to use it.

Also, a new tool is now available for easy downgrading to iOS 5.0, called "iFaith," is a Windows application, and it lets you circumvent Apple's restricted downgrade system which prevents people from downgrading their devices to an older iOS 5.x firmware.

The new version, iFaith 1.4, works around that Apple-imposed limitation by permitting unsigned restores based on dumped iOS 5 signature hash blobs. This is important because, as noted by MuscleNerd, an upcoming untethered iOS 5 jailbreak might require iFait for user restores.

According to the iFaith developer, iH8sn0w, it is possible to restore to iOS 5.0.1 and preserve iPhone 4 baseband by dumping the blobs with iFaith first. The tool does not support A5 devices yet. Because the sn0wbreeze tool (another iH8sn0w's creation) isn't capable of iFaith blobs yet, users are advised to use the redsn0w app.

For more information wathc the video tour below: