Chrome Warns Users, Dashed-out 'Out-of-date Browser Plugins'

The latest release of Google Chrome isn't only speedier and simpler but it also improves user security by automatically disabling out-of-date, vulnerable browser plugins. Users will now be automatically warned about any out-of-date plugins. If you run into a page that requires a plugin that's not current, it won't run by default. Instead, you'll see […]

The latest release of Google Chrome isn't only speedier and simpler but it also improves user security by automatically disabling out-of-date, vulnerable browser plugins. Users will now be automatically warned about any out-of-date plugins. If you run into a page that requires a plugin that's not current, it won't run by default. Instead, you'll see a message that will help you get the latest, most secure version of the plugin.

As browsers get better at auto-updating, out-of-date plugins are becoming the weakest link against malware attacks. Thousands of web sites are compromised every week, turning those sites into malware distribution vectors by actively exploiting out-of-date plugins that run in the browser.

"Keeping all of your plugins up-to-date with the latest security fixes can be a hassle, so a while ago we started using our 20% time to develop a solution. The initial implementation was a Chrome extension called "SecBrowsing," which kept track of the latest plugin versions and encouraged users to update accordingly. The extension helped us gather valuable knowledge about plugins, and we started working with the Chrome team to build the feature right inside the browser," Google explains.

[Source]