Adobe Flash Player and Reader Vulnerabilities Patched, Updates Now Available for Download

Just recently, a new critical vulnerability was identified in Adobe Reader and Flash Player 10.2.152.33 and earlier versions for Chrome users, for Windows, Macintosh, Linux, Solaris operating systems, and Android. While Google and Adobe managed to deliver an update to secure Chrome users, it took a few more days to put together the necessary bits […]

Just recently, a new critical vulnerability was identified in Adobe Reader and Flash Player 10.2.152.33 and earlier versions for Chrome users, for Windows, Macintosh, Linux, Solaris operating systems, and Android. While Google and Adobe managed to deliver an update to secure Chrome users, it took a few more days to put together the necessary bits for the general Flash and Reader using public.

Adobe has now posted an update for both Reader and Flas player. Adobe recommends users of Flash Player 10.2.152.33 and earlier update to Flash Player 10.2.153.1 -- Flash Player 10.1.106.16 and earlier update to 10.2.156.12. And users of Adobe AIR 2.5.1 and earlier versions must update to Adobe AIR 2.6.

You should be notified via the Adobe Updater that a new version is available, but you can always download manually as well. We'd recommend doing so immediately rather than waiting on a notification.

To verify the version of Adobe Flash Player for Android, go to Settings > Applications > Manage Applications > Adobe Flash Player 10.x,

To verify the version of Adobe AIR installed on your system, follow the instructions in the Adobe AIR TechNote.

You can find the updated Flash Player and Reader downloads on Adobe's site.

[Source]