Google 'Android Compatibility Package' Anti-fragmentation Kit Released

Google released a Fragment API in February that enabled better cross-compatibility with different versions of Android and different form factors. However, that API was geared towards application developed in Honeycomb (3.0).Google now has released a new "Android Compatibility package" which helps developers combat fragmentation-related issues.The new released static library exposes the same Fragments API (as […]

Android Logo

Google released a Fragment API in February that enabled better cross-compatibility with different versions of Android and different form factors. However, that API was geared towards application developed in Honeycomb (3.0).

Google now has released a new "Android Compatibility package" which helps developers combat fragmentation-related issues.

The new released static library exposes the same Fragments API (as well as the new LoaderManager and a few other classes) so that applications compatible with Android 1.6 or later can use fragments to create tablet-compatible user interfaces.

Googles fragmentation problems are a direct result of carriers delaying or blocking Google updates to their proprietary versions of Android. The open source OS is modified at virtually every carrier/manufacturer, so they become the gatekeepers of the update path. Google has already released Honeycomb to the masses, but only the Motorola Xoom have taken advantage of it, while Gingerbread (2.3) has only been officially shipped on the Nexus S. While everyone plays catch-up, developers are stuck between a rock and a hard place trying to develop for as many different platform as possible. According to many, this leads to lower quality applications, and will always lag behind tighter platforms like iOS.

This library is available through the SDK Updater.

[Source]