Sunset for Google Earth COM API - Future Releases To Support JavaScript API

Google announced that "Google Earth 5.2 and older clients will be the last version that supports the COM API while these versions are supported." And, that "future releases will no longer have COM API bindings." "We believe that JavaScript API provides the best mechanism for reaching the most developers," said Google."We realize that a few […]

Google announced that "Google Earth 5.2 and older clients will be the last version that supports the COM API while these versions are supported." And, that "future releases will no longer have COM API bindings." "We believe that JavaScript API provides the best mechanism for reaching the most developers," said Google.

"We realize that a few of you'll be disappointed by this news, however we're happy to work with you to transition off of COM onto JavaScript. Please see the documentation for more information on how to work with Earth API, and visit developer forum for support. Enterprise customers can also contact Enterprise support with any questions. If you've a feature from COM that you can't live without, please let us know about it by adding it as a feature request in our issue tracker, and starring other requests," stated Google.

[Source]