Fix for "Connecting to VM in SCVMM fails with "Virtual Machine Manager lost the connection to the virtual machine..." error

"When authenticated to System Center Virtual Machine Manager Self-Service Portal (SSP), selecting a Virtual Machine hosted on Hyper-V and clicking "Connect to VM" results in error message displayed on a white screen: "Virtual Machine Manager lost the connection to the virtual machine because another connection was established to this machine."The reason this can occur is […]

"When authenticated to System Center Virtual Machine Manager Self-Service Portal (SSP), selecting a Virtual Machine hosted on Hyper-V and clicking "Connect to VM" results in error message displayed on a white screen: "Virtual Machine Manager lost the connection to the virtual machine because another connection was established to this machine."

The reason this can occur is because credentials for user account logged onto Windows (User1) are passed through instead of those used to authenticate to SSP (User2). By default "Do not store my credentials" radio button is selected which causes this behaviour. User1 can be authenticated on Hyper-V host, but Authorization Manager (AzMan) fails to find any record of their privileges to connect to VM's console.(As authentication succeeds, it's not considered a "failed logon attempt".)," explains Microsoft.

To resolve: "select the radio button "Store my credentials" on logon page of SSP. By doing this, the credentials entered here're passed through when "Connect to VM" is clicked," KB2288932.