WordPress 3.1 "last to support PHP 4 and MySQL 4" and WordPress 3.2 need PHP 5.2+ and MySQL 5.0.15+

WordPress dev team announced the end of support for PHP 4 and MySQL 4! "WordPress 3.1, due in late 2010, will be the last version to support PHP 4 and MySQL 4. And, WordPress 3.2, due in the first half of 2011, will require PHP 5.2 or higher, and MySQL 5.0.15 or higher. It's also […]

WordPress dev team announced the end of support for PHP 4 and MySQL 4! "WordPress 3.1, due in late 2010, will be the last version to support PHP 4 and MySQL 4. And, WordPress 3.2, due in the first half of 2011, will require PHP 5.2 or higher, and MySQL 5.0.15 or higher. It's also the minimum PHP version that Drupal and Joomla projects will be supporting in their next versions, both due out this year," WordPress stated.

"Only around 11% WordPress installs are running PHP version below 5.2. Many of them are on hosts who support PHP 5.2 — users just need to activate from their hosting control panel."

Noe WordPress users willn't be able to upgrade to 3.2 if their hosting environment doesn't meet these requirements. You can use Health Check plugin which'll tell you if you're ready for WordPress 3.2.

[Source]