IE8 RC1 for Windows Vista, XP soon to be released

Over the past months, our compatibility team has been hard at work, finding and fixing bugs that cause site rendering issues. Due to the different release schedules for Windows 7 Beta and IE8 RC1, some of these bug fixes didn't make it into Windows 7 Beta (aka Build 7000). So, if you want to use […]
Over the past months, our compatibility team has been hard at work, finding and fixing bugs that cause site rendering issues. Due to the different release schedules for Windows 7 Beta and IE8 RC1, some of these bug fixes didn't make it into Windows 7 Beta (aka Build 7000). So, if you want to use the latest version of IE8 – you’ll want to install Intdernet Explorer 8 RC1 for Windows Vista or Windows XP,” Olivier explained.