Microsoft IE8 incompatible with Yahoo! Mail & Gmail

Microsoft Internet Explorer 8 beta 1 was recently released and, lots of people downloaded,  installed and tested it. However, some of them may have encounter unexpected problems because IE8 doesn't support several important web services, including Gmail and Yahoo Mail. In fact, you may manage to log in using the "Emulate IE7" function but, the compatibility issues still […]

Microsoft Internet Explorer 8 beta 1 was recently released and, lots of people downloaded,  installed and tested it. However, some of them may have encounter unexpected problems because IE8 doesn't support several important web services, including Gmail and Yahoo Mail. In fact, you may manage to log in using the "Emulate IE7" function but, the compatibility issues still exist.


Gmail: Gmail, Google's mail service available for free for anyone interested in it, supports multiple browsers as the Mountain View-based company mentions in the Help Center. Gmail works with Firefox 2.0 (Windows, Mac and Linux) and Internet Explorer 7 for Windows but you may also use it with other browsers, although it wouldn't be fully functional, such as IE 5.5+, Safari 1.3+, Netscape 1.4+ and others. Moreover, for IE 4.0+, Netscape 4.07+ and Opera 6.03+, you'll only get the basic HTML view of Gmail.

Now let's see what happens when trying to access Gmail with Internet Explorer 8. First of all, the default version of the browser, without the emulation of IE7; as you can see, I managed to log in into my Gmail account but it's all messed up and it looks like... Moreover, clicking on any link inside it, no matter if we're talking about settings or an inbox message, takes approximately 5 seconds until it's opened.

Internet Explorer 8 with IE7 emulation: the service works fine but the left menu which allows you to browse among the Gmail folders looks different and occupies more space on your screen.

Yahoo Mail: The new Yahoo Mail states that it supports IE 6.0 and newer, Firefox 1.0 and newer and Safari 2.0 and newer, on Windows 200, XP, Vista or later and Mac OSX or later. Since it says that IE 6.0 and newer is supported, this would obviously mean that later releases, including IE 8, are also compatible. Well, they're not. When trying to access Yahoo Mail with Internet Explorer, I got the well-known error: "Hmm... your browser is not officially support. The all-new Yahoo Mail hasn't been tested on your browser. You can choose to continue, or simply go to Yahoo Mail Classic."

Source:→ Softpedia

Microsoft, Yahoo!, Google, Webmail, Yahoo! Mail, Gmail, Internet Explorer 8, IE8