YUI Version 2.2.1 Released

The YUI blog announced the release of version 2.2.1 of the Yahoo User Interface (YUI) Library, which is primarily about bug fixes, but it’s much improved now with many significant fixes such as: The pagination API has been refactored and updated. Row selection has been changed to better mimic the desktop paradigm. Scrolling is now […]
The YUI blog announced the release of version 2.2.1 of the Yahoo User Interface (YUI) Library, which is primarily about bug fixes, but it’s much improved now with many significant fixes such as:

  • The pagination API has been refactored and updated.
  • Row selection has been changed to better mimic the desktop paradigm.
  • Scrolling is now customizable via CSS.
  • Table messaging has been improved for empty and error states.
  • A number of other smaller fixes, including:
    • Links within the body of the table
    • Column sorting of empty values
    • Fields with the name “id”
    • Resizability in the -min build
    • And many more!

onDOMReady —We’re happy to announce the inclusion of the onDOMReady event in the Event utility! Now YUI developers can execute their JavaScript when the DOM loads, and before everything else loads too. This utility also provides the onAvailable event, which fires when a specified DOM node loads, and the onContentReady event, which fires when a specified DOM node, plus all of its children, loads.

Graded Browser Support Update: We typically provide an update to our chart of A-Grade browsers at the beginning of each quarter. There are two important changes in this update. First, we’ve initiated A-grade support for Firefox 2.† and IE 7.0 on Windows Vista. Second, we’ve started to use the dagger symbol (†) to indicate a single flexible version number that receives support.

The dagger symbol (as in “Firefox 2.†&Prime) indicates that “the latest single non-beta version at that branch level” receives support. Put another way, “Firefox 2.†&Prime means we support v2.0.0.4, but not v2.0.0.3 (because it’s not the single newest) nor v3.0 (because that’s outside of the 2.† branch). If Firefox 2.0.0.5 is released, 2.0.0.4 will no longer receive A-grade support; † means “the most recent” instead of “all.”

Download

Source:→ YUI Blog

Yahoo!, YUI, Development, release, javascript, library, datatable, event, a-grade, gradedbrowsersupport